金苏股票大宝库

通达信黑马起飞主图指标

帮忙把公式改成通达信

{OK.通达信测试通过}
VAR1:=EMA(C,5),LINETHICK0;
VAR2:=EMA(C,10),LINETHICK0;
VAR3:=EMA(C,20),LINETHICK0;
VAR4:=EMA(C,30),LINETHICK0;
VAR5:=(VAR1+VAR2+VAR3+VAR4)/4,LINETHICK0;
VAR6:=(VAR5-REF(VAR5,15))/REF(VAR5,15)*100,LINETHICK0;
VAR7:=EMA(VAR6,8),LINETHICK0;
STICKLINE(VAR6<1*REF(VAR6,1),H,L,0,0),COLORBLUE;
STICKLINE(VAR6<1*REF(VAR6,1),O,C,3, 0),COLORBLUE;
STICKLINE(VAR6>1*REF(VAR6,1),H,L,0,0),COLORRED;
STICKLINE(VAR6>1*REF(VAR6,1),O,C,3, 0),COLORRED;
STICKLINE(VAR6<1*REF(VAR6,1) AND VAR7>1*REF(VAR7,1),H,L,0,0),COLORGREEN;
STICKLINE(VAR6<1*REF(VAR6,1) AND VAR7>1*REF(VAR7,1),O,C,3, 0),COLORGREEN;
BYX:=MA(CLOSE,8),LINETHICK0;
DRAWBAND(BYX,RGB(255,0,0),REF(BYX,1),RGB(0,250,0));
MA1:MA(CLOSE,5);
MA2:MA(CLOSE,10);
MA3:MA(CLOSE,20);
MA4:MA(CLOSE,30);
MA65:MA(CLOSE,65);
MA130:MA(CLOSE,130);
SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,13)/HHV(C,13))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,13)/HHV(C,13))*100),LINETHICK0;
GLBA1:=MA1>REF(MA1,1),LINETHICK0;
GLBA2:=MA2>REF(MA2,1),LINETHICK0;
GLBA3:=MA1>REF(MA3,1),LINETHICK0;
GLBA4:=MA1>REF(MA4,1),LINETHICK0;
DTPL:=CLOSE>=MA1 AND MA2>=MA1 AND MA3>=MA4,LINETHICK0;
DTPL0:=COUNT(DTPL,20),LINETHICK0;
GZD:=GLBA1 AND GLBA2 AND GLBA3 AND GLBA4,LINETHICK0;
MA0:=(MA1+MA2+MA3+MA4)/4,LINETHICK0;
MA1A:=MA(MA0,8),LINETHICK0;
GZDNUM:=LONGCROSS(MA0,MA1A,1),LINETHICK0;
SATCOUNT:=LONGCROSS(SAT,100,21),LINETHICK0;
GLBBIF5:=LONGCROSS(CLOSE,MA4,5),LINETHICK0;
VGLBH:=VOL/CAPITAL*100,LINETHICK0;
LBGLB:=VOL/MA(VOL,5),LINETHICK0;
DRAWTEXT(GLBBIF5,LOW,'葛兰碧第一买点'),COLORBLUE;
DRAWTEXT(GZDNUM AND GZD AND C>MA4 ,LOW,'多周期向上共振---积极介入点'),COLORRED;
DRAWTEXT(SATCOUNT AND VGLBH>2.0 AND LBGLB>1.0,LOW-1.0,'量能饱和点,即将起飞'),COLORYELLOW;
A1:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),LINETHICK0;
HM0:=EMA(A1,5),LINETHICK0;
A2:=(HM0-REF(HM0,1))/REF(HM0,1)*100,LINETHICK0;
A3:=EMA(C,5),LINETHICK0;
A4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100,LINETHICK0;
QS0:=(MA(3*SMA(A4,6,1)-2*SMA(SMA(A4,5,1),5,1),2)),LINETHICK0;
A5:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*100,LINETHICK0;
DRAWTEXT(FILTER(REF(HM0,1)>90 AND A2<0,7),HIGH+2,'跑!'),COLORGREEN;
DRAWTEXT(CROSS(HM0,A5)AND QS0<80,LOW-2.5,'追涨'),COLORYELLOW;
DRAWTEXT(CROSS(QS0,0)AND HM0<40,LOW-3,'大黑马'),COLORRED;
DRAWICON(A2<-10 AND A2>REF(A2,1) AND A3>REF(A3,1),LOW-2,4);
DRAWTEXT(A2<-10 AND A2>REF(A2,1) AND A3>REF(A3,1),LOW-2,'底部来临'),COLORYELLOW;

如何利用通达信软件自带选股器选出波段振幅特大的股?

最好别用这些东西,不然最终的结果往往是死都不知道怎么死的...

把以下公式里“发现黑马”信号改为选股预警公式

VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
组合买: =(VAR11+VAR13+VAR15+VAR17);
发现黑马:组合买=4;
经测试,选股正常。不过,公式选用未来函数,建议慎用。
股票公式专家团为你解答,希望能帮到你,祝投资顺利。
你的采纳对我是最大的鼓励。

急急请高手帮忙 组合通达信的选股公式和预警公式 (超级黑马 去)

A00:=SUM(IF((CLOSE> REF(CLOSE,1.000)),VOL,IF((CLOSE<REF(CLOSE,1.000)),(0-VOL),0)),0);A01:=SUMBARS(VOL,CAPITAL);A02:=IF((CLOSE>LLV(CLOSE,A01)),1.000,(0-1.000))*IF((A00 >LLV(A00,A01)),1.000,(0-1.000));A03:=(COUNT((IF((A02=(0-1.000)),1.000,0)=1.000),8.000)>2.000);A04:=((CLOSE-DMA((((3.000 * HIGH + LOW)+OPEN)+2.000 * CLOSE)/7.000,VOL/SUM(AMOUNT,13.000)/AMOUNT/VOL/100.000/100.000))/DMA((((3.000*HIGH+LOW)+OPEN)+2.000*CLOSE)/7.000,VOL/SUM(AMOUNT,13.000)/AMOUNT/VOL/100.000/100.000)*100.000<(0-18.000));A05:=((CLOSE-MIN(REF(CLOSE,5.000)*0.865,REF(CLOSE,21.000)*0.772))/CLOSE<0.009);A06:=((A03 AND A04) AND A05);A07:=(((((OPEN < EMA(CLOSE,5.000)) AND (CLOSE=HIGH)) AND (CLOSE/OPEN>=1.05)) AND (VOL/CAPITAL>=0.019)) AND (VOL/CAPITAL<=0.200));A08:=(A07 AND (COUNT(A07,5.000)=1.000));A09:=((((((((((((MA(CLOSE, 3.000)>REF(MA(CLOSE,3.000),1.000)) AND (MA(CLOSE, 5.000)>REF(MA(CLOSE,5.000),1.000))) AND (MA(CLOSE,10.000)>REF(MA(CLOSE,10.000),1.000))) AND(VOL/240.000>REF(VOL,30.000)*1.200/240.000*1.500)) AND (CLOSE>LOW*1.059)) AND (CLOSE>REF(MA(CLOSE,3.000),1.000))) AND REF(CLOSE,1.000)) AND (MA(CLOSE,5.000)>REF(MA(CLOSE,5.000),1.000))) AND (MA(CLOSE,10.000)>REF(MA(CLOSE,10.000),1.000))) AND (MA(CLOSE,20.000)>REF(MA(CLOSE,20.000),1.000))) AND (MA(VOL,5.000)>REF(MA(VOL,5.000),1.000))) AND ((MA(CLOSE,5.000)-MA(CLOSE,10.000))<= 0.579));A0A:=FILTER(A09,5.000);
超级黑码:=((A06 OR A07) AND A0A);
PN1:=DYNAINFO(8)>0;PN2:=DYNAINFO(17)>0;PN3:=DYNAINFO(22)>0;PN4:=DYNAINFO(23)>0;ST:=IF(NAMELIKE('ST')=1,0,IF(NAMELIKE('S ST')=1,0,IF(NAMELIKE('*ST')=1,0,1)));
去除:=PN1*PN2*PN3*PN4*ST;
XG:超级黑码 AND 去除;

(已测试)